GIMP for Windows

Problem with Trust Tablet

Gimp for Windows XP SP3 or later

Problem with Trust Tablet

Postby Gan » Tue Dec 27, 2011 9:59 am

Hi guys!

New to the forum. I've been using GIMP for a lot of time, and I finally bought a new tablet. Well, in the store they had only this: Trust Tablet Slimline Design.

Installed it, updated the drivers, try it on GIMP, doesn't work. If I use it without pressure, it works good. If I set the input to Screen or Windows mode, then there are some problems. The brush dot is offset to the left from the cursor. I've uploaded a screenshot to make you see what I'm talking about.

Strange fact: I downloaded MyPaint, and the problem is actually the same. Same thing with Inkscape. But I downloaded a Photoshop trial and it worked good.

I hope the problem is the same for MyPaint and Inkscape, and not only for GIMP. I repeat: if I disable the pressure, the pen works good.

Do you guys have some tricks or solutions for this (annoying) problem? Maybe some preferences/settings I'm missing?

Here's the screen I was talking about: . As you can see, that is the same line done with the pen and the mouse. The pen's one is offset to the left, the mouse one is good.
Members don't see the above ad. Register now - it's free!
Gan
Newbie
 
Posts: 3
Joined: Tue Dec 27, 2011 9:47 am

Re: Problem with Trust Tablet

Postby Arzoroc » Tue Dec 27, 2011 3:59 pm

I remember that I had the same problem once.. but I really don't remember how I got rid of it..
Inactive.
Spoiler: show
Willy wrote:arzorac

Maffe811 wrote:Arcoroc

David Wood wrote:Arzorac

sagtek wrote:Arzonic

Legionenigmatics wrote:azornac

Cyrilshark wrote:Argzornack, I still have to congratulate you on having the most epic signature ever. haha

*bow*
User avatar
Arzoroc
Global Moderator
 
Posts: 2199
Joined: Mon Oct 12, 2009 1:34 pm

Re: Problem with Trust Tablet

Postby Gan » Tue Dec 27, 2011 4:03 pm

Oh thanks Arzoroc (I hope I spelt your name right :D )

At least, I'm now sure that I'm not the first to get this problem... If you'll remember or someone else has the solution, please tell me.

Bye!
Gan
Newbie
 
Posts: 3
Joined: Tue Dec 27, 2011 9:47 am

Re: Problem with Trust Tablet

Postby Arzoroc » Tue Dec 27, 2011 4:20 pm

Well, I was talking about the offset problem on Screen mode. Try something: The brush display is offset to the left, isn't it? Try moving the cursor as far to the left as possible and see whether it does not fit your resolution settings (i.e. you're halfway to the left but the mouse cursor is already at the very end of your screen OR you're already at the end of your tablet but the mouse cursor is not yet at the border of your screen). Also try this with the right side. If there's something wrong here, your tablet is working with another resolution as your PC.
The pressure problem is new to me, I'm using a Wacom tablet though. Is your tablet capable of displaying pressure levels at all? Do you know that it works with Gimp for other people?
Inactive.
Spoiler: show
Willy wrote:arzorac

Maffe811 wrote:Arcoroc

David Wood wrote:Arzorac

sagtek wrote:Arzonic

Legionenigmatics wrote:azornac

Cyrilshark wrote:Argzornack, I still have to congratulate you on having the most epic signature ever. haha

*bow*
User avatar
Arzoroc
Global Moderator
 
Posts: 2199
Joined: Mon Oct 12, 2009 1:34 pm

Re: Problem with Trust Tablet

Postby Gan » Tue Dec 27, 2011 4:36 pm

The problem is when I activate the pressure.
While it is "Disabled", the pen works very good. When I activate it, the brush is offset and make strange lines (see screenshots). Something is wrong with the axis, maybe.

Just a thing I noted: on the Trust Setting Panel, in the Pressure tab, when I try to click the offset is to the right... very strange. Perhaps the problem is just the tablet, and not tablet-software.

Going to see something on Google, thanks!

If anyone has same problems with tablet, please explain your solution.
Gan
Newbie
 
Posts: 3
Joined: Tue Dec 27, 2011 9:47 am


Return to GIMP for Windows

Who is online

Users browsing this forum: No registered users and 1 guest