GIMP for Mac

Serious problems gimping. [SOLVED]

Installation and Mac OS specific issues.

Serious problems gimping. [SOLVED]

Postby alaskatroll » Wed May 16, 2012 4:46 am

Hi all! Thanks in advance for your time...

I'm new to these forums, and was hoping that someone could help me with major complications I've recently been having with Gimp. They suddenly appeared, I had never had problems with Gimp, and when I fired it up for the first time after a while, Everything seemed to have gone to shit. That was with 2.6.1. I installed 2.8.0, hoping that would fix it, but it only introduced more problems.

Sadly, there are numerous things wrong, I'll list them in order of how problematic they are:

- Gimp crashes a lot... whenever I try to do something, really.

- I can't move the windows. In fact, there's no title bar for any of them.

- I can only resize the main view window in the lower right corner. Can't resize anything else.

- Whenever the normal cursor should appear, it shows the black x-shaped cursor instead. weird.

I had an issue where whenever I tried to edit the preferences, I got an error saying permission was denied to create library/application support/gimprc, even though I have read & write permissions on all of the files in the folder... but when I changed the permissions of "everyone" from read-only to read & write, that issue disappeared. strange, and I think it has something to do with the problems I'm still having.

I tried reinstalling gimp and xquartz, to no avail.

someone please help me!
Members don't see the above ad. Register now - it's free!
Last edited by alaskatroll on Fri May 18, 2012 7:20 am, edited 1 time in total.
alaskatroll
Newbie
 
Posts: 3
Joined: Wed May 16, 2012 4:32 am

Re: Serious problems gimping.

Postby Maffe811 » Wed May 16, 2012 1:12 pm

Try this:

Rod wrote:Could you both please try this install for Gimp-2.8 instead and tell me how it works?
I use this version for Windows XP 32 bit and no problems thus far with JPG exporting.
Please make sure and install the correct version.

These by the way DO NOT uninstall Gimp-2.6.
They are also packed with working Python27 out of the box.
Just install into normal Program default directories where you would normally install programs for your particular os.

32 bits - http://www.partha.com/downloads/Gimp-2.8-32bit.exe
64 bits - http://www.partha.com/downloads/Gimp-2.8-64bit.exe

Thanks
Got möp?
Image
SOTW #1 ^
"Photoshop!? You don't need no stinkin' Photoshop" - We'll show you the power of the Gimp!!!
---
Honest CnC always beats crap CnC
Baum wrote:I think it doesnt has to be mentioned that self-voters have a small p....hotograph :D
User avatar
Maffe811
Global Moderator
 
Posts: 6810
Joined: Thu Jul 02, 2009 1:00 pm
Location: Norway/Norge/Norwegen

Re: Serious problems gimping.

Postby Arzoroc » Wed May 16, 2012 6:20 pm

Maffe, this is in the Mac forum, so I think this is for Mac, not Windows.

Alaskatroll, did you download Gimp from lisanet? Also, have you tried uninstalling everything related to Gimp (that is, delete the Gimp folders everywhere etc) and reinstalling from scratch with an official file from an official Gimp website?

Have you got any problems with other programs similar to Gimp? (I don't know about any of the techy stuff, but python is run by some programs isn't it? *ducks in case he said something wrong*) A clean install should always be flawless, so if there's a problem, it's probably your computer that causes them.

As you mentioned the rights-issues, have you tried starting Gimp with SU? (terminal > sudo gimp did the job in Ubuntu Linux). Did you run the installation as SU/Admin?
... If it's none of this, I can't help you I guess..
Maybe wait for the more techy guys around here, or even send a PM to lisanet.
Inactive.
Spoiler: show
Willy wrote:arzorac

Maffe811 wrote:Arcoroc

David Wood wrote:Arzorac

sagtek wrote:Arzonic

Legionenigmatics wrote:azornac

Cyrilshark wrote:Argzornack, I still have to congratulate you on having the most epic signature ever. haha

*bow*
User avatar
Arzoroc
Global Moderator
 
Posts: 2199
Joined: Mon Oct 12, 2009 1:34 pm

Re: Serious problems gimping.

Postby Maffe811 » Wed May 16, 2012 7:51 pm

Sorry, i was in a hurry for practice, didn't pay attention.
Got möp?
Image
SOTW #1 ^
"Photoshop!? You don't need no stinkin' Photoshop" - We'll show you the power of the Gimp!!!
---
Honest CnC always beats crap CnC
Baum wrote:I think it doesnt has to be mentioned that self-voters have a small p....hotograph :D
User avatar
Maffe811
Global Moderator
 
Posts: 6810
Joined: Thu Jul 02, 2009 1:00 pm
Location: Norway/Norge/Norwegen

Re: Serious problems gimping.

Postby alaskatroll » Thu May 17, 2012 4:07 am

Arzoroc wrote:Maffe, this is in the Mac forum, so I think this is for Mac, not Windows.

Alaskatroll, did you download Gimp from lisanet? Also, have you tried uninstalling everything related to Gimp (that is, delete the Gimp folders everywhere etc) and reinstalling from scratch with an official file from an official Gimp website?

Have you got any problems with other programs similar to Gimp? (I don't know about any of the techy stuff, but python is run by some programs isn't it? *ducks in case he said something wrong*) A clean install should always be flawless, so if there's a problem, it's probably your computer that causes them.

As you mentioned the rights-issues, have you tried starting Gimp with SU? (terminal > sudo gimp did the job in Ubuntu Linux). Did you run the installation as SU/Admin?
... If it's none of this, I can't help you I guess..
Maybe wait for the more techy guys around here, or even send a PM to lisanet.


I did a clean reinstall from lisanet. I deleted the gimp folder in applciation support... Are there any other files I should have removed?

I also deleted both XQuartz and X11, and then did a clean re-install of just XQuartz 2.7.1. Then, when I launched gimp, it asked me to locate X11. So I chose XQuartz.app, and nothing was fixed. So I checked out the console, and it says:
Code: Select all
5/16/12 8:03:20.721 PM org.macosforge.xquartz.startx: waiting for X server to begin accepting connections
5/16/12 8:03:20.722 PM org.macosforge.xquartz.startx: waiting for X server to begin accepting connections No protocol specified

every 2 seconds. finally, it says

Code: Select all
5/16/12 8:03:36.806 PM org.macosforge.xquartz.startx: /opt/X11/bin/xinit: giving up
5/16/12 8:03:36.806 PM org.macosforge.xquartz.startx: /opt/X11/bin/xinit: unable to connect to X server: Operation timed out
5/16/12 8:03:36.807 PM org.macosforge.xquartz.startx: waiting for X server to begin accepting connections
5/16/12 8:03:36.809 PM [0x0-0x82082].org.gimp.Gimp: gimp-2.8: Fatal IO error 35 (Resource temporarily unavailable) on X server /tmp/launch-5GYNb8/org.macosforge.xquartz:0.
5/16/12 8:03:36.821 PM [0x0-0x82082].org.gimp.Gimp: (script-fu:1038): LibGimpBase-WARNING **: script-fu: gimp_wire_read(): error
5/16/12 8:03:37.808 PM org.macosforge.xquartz.startx: waiting for X server to shut down
5/16/12 8:03:37.808 PM org.macosforge.xquartz.startx: /opt/X11/bin/xinit: server error
5/16/12 8:03:38.004 PM org.macosforge.xquartz.startx: waiting for X server to shut down


That's when gimp crashes.

Does that help anyone? Anyone know XQuarts well? I love my gimp :'(
alaskatroll
Newbie
 
Posts: 3
Joined: Wed May 16, 2012 4:32 am

Re: Serious problems gimping.

Postby Maffe811 » Fri May 18, 2012 1:32 am

There was this one guy who knew something.
Got möp?
Image
SOTW #1 ^
"Photoshop!? You don't need no stinkin' Photoshop" - We'll show you the power of the Gimp!!!
---
Honest CnC always beats crap CnC
Baum wrote:I think it doesnt has to be mentioned that self-voters have a small p....hotograph :D
User avatar
Maffe811
Global Moderator
 
Posts: 6810
Joined: Thu Jul 02, 2009 1:00 pm
Location: Norway/Norge/Norwegen

Re: Serious problems gimping. [SOLVED]

Postby alaskatroll » Fri May 18, 2012 7:23 am

Hey guys, I finally figured it out. Apparently the issue lied with unix permissions and access control lists. They were probably interfering with both the installation and running of both Xquartz and gimp. I reset the permissions and ACLs to default on my home drive, and after reinstalling both XQuartz and gimp, no problems.

So, if anyone else ever has this problem, or any other weird problems, tell them to reset their permissions and ACLs.
alaskatroll
Newbie
 
Posts: 3
Joined: Wed May 16, 2012 4:32 am

Re: Serious problems gimping. [SOLVED]

Postby Maffe811 » Fri May 18, 2012 10:49 am

Thank you for that!
I hate when people fix it, but doesn't report back.
So forum guys keeps looking for solution and if they doesn't find it then its never solved!
Once again, thank you! :)
Got möp?
Image
SOTW #1 ^
"Photoshop!? You don't need no stinkin' Photoshop" - We'll show you the power of the Gimp!!!
---
Honest CnC always beats crap CnC
Baum wrote:I think it doesnt has to be mentioned that self-voters have a small p....hotograph :D
User avatar
Maffe811
Global Moderator
 
Posts: 6810
Joined: Thu Jul 02, 2009 1:00 pm
Location: Norway/Norge/Norwegen


Return to GIMP for Mac

Who is online

Users browsing this forum: No registered users and 4 guests