1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Trouble using the move tool

Discussion in 'GIMP for Mac' started by jbarch, Jan 21, 2009.

  1. jbarch

    jbarch New Member

    Joined:
    Jan 21, 2009
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Hi,
    This seems like an idiot question, but then I'm a newbie to GIMP....

    I'm pulling my hair out with the move tool. I cannot get it to move a selection, it will only move a layer. I have found the tool option for "move selection" instead of "move layer", but all this does is to move the marquee... I actually want to move the stuff inside the marquee, leaving a blank space where the object was originally.

    The workaround for this is to select the area I want to move, then cut, then paste and move the floating selection. But I'd sure like to avoid this step and simply move stuff freely. I'll attach before and after files to show what I am trying to achieve.

    I feel like I've checked the obvious stuff, e.g. I am sure to be working on the active layer... what else am I overlooking?

    Thanks in advance.

    p.s. I am using Gimp 2.6.4 on OS 10.4.11.
     
  2. jbarch

    jbarch New Member

    Joined:
    Jan 21, 2009
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Hmm.. I can move the entire layer, no problem. What I'm after is the ability to grab part of a layer and move it, kind of like an abbreviated cut/paste.

    I have now figured out that I can do this by using the rectangular marquee tool, then using option+control+click to drag the selection around. I thought I had tried this before but who knows.

    Thanks.
     
  3. wealthychef

    wealthychef New Member

    Joined:
    Jan 31, 2009
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    I am having the same problem. I have an image, and want to select part of it and move it to another part of the window. This should be trivial, but it does not seem possible. Control-alt-click is what the user manual says to use, but this does not work. I'm definitely wondering what the parent poster did to make it work suddenly.
    I am using Gimp 2.6.4 on OS X 10.5.6.
     
  4. mdgunn

    mdgunn New Member

    Joined:
    Feb 4, 2009
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    After creating a selection just press CTRL+ALT then move with the mouse straight away.

    Don't be tempted to select the move tool, even though that is clearly the sort of operation you are trying to perform(!?!?!?!).

    In my opinion this seems to be incorrect behaviour and a bug. Surely if a selection is in effect then all operations should only affect the selection?
     
  5. mdgunn

    mdgunn New Member

    Joined:
    Feb 4, 2009
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Forgot to mention. I'm on Windows with 2.6.4 in case my particular problem was a Windows only 'feature'.
     
  6. wealthychef

    wealthychef New Member

    Joined:
    Jan 31, 2009
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Nope, as I said, ctrl-alt does not work for me on OS X 10.5 . I am not using the move tool at all for anything (what is it for, if not to move things?) If I follow your instructions, all that happens is a new selection gets subtracted or added somehow. Perhaps it has to do with the X11 preferences. You can see what happens in this movie: http://wealthychef.com/gimp/X11ScreenSnapz001.mov. The drags I do are all with the control and alt key held down. You can see the cursor change from having a plus to a minus sign when I press control-alt. It's as if the control key is being ignored.
     
  7. ouroboros

    ouroboros New Member

    Joined:
    Sep 5, 2009
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    I have the exact same problem on OSX 10.5.8. Anyone get to the bottom of this bug?
     
  8. lisanet

    lisanet Member

    Joined:
    Sep 15, 2008
    Messages:
    221
    Likes Received:
    0
    Trophy Points:
    16
    CTRL + X
    CTRL + V
    Move it!

    You've already answerded your question by yourself:

    your're moving the selection, not the contents of the selection. So do move the contents... read above.

    -skl
     
  9. ouroboros

    ouroboros New Member

    Joined:
    Sep 5, 2009
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    eh! Of course copy/paste works as expected, but you still have the original thing you wanted to move in the old place!!!

    All I want to do, like on every other paint program is highlight an area and either be able to click and move it directly, or click on the move tool and have it properly move the selection. It seems on Mac osx, under X11 something does not work and you can only move the whole image/layer.
     
  10. ouroboros

    ouroboros New Member

    Joined:
    Sep 5, 2009
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    "After creating a selection just press CTRL+ALT then move with the mouse straight away. "

    This just draws another selection on OSX. And the move tool ignores the selection and moves the whole image. :question:
     
  11. lisanet

    lisanet Member

    Joined:
    Sep 15, 2008
    Messages:
    221
    Likes Received:
    0
    Trophy Points:
    16
    CTRL + X = cut

    Another solution is to change the keyboard layout X11 is using to get a ALT key. You need to edit (or create) the file ".Xmodmap" in your home directory.

    If you want to put e.g. ALT on the left alt-key on your keyboard, your .Xmodmap should have the following lines

    Code:
    clear mod1
    keycode 66 = Alt_L
    add mod2 = Mode_switch
    
    You have to restart both, GIMP and X11.
    IMO most Mac users don't want to edit some dot files in their home directory, CTRL + X, CTRL + V is much easier.

    -skl
     
  12. ouroboros

    ouroboros New Member

    Joined:
    Sep 5, 2009
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Hi,

    I have no issue editing a text file for keyboard allocations. However I'm concerned this doesn't solve the problem anyway. Even if you use the menus etc, there does not seem to be a way to move a selection on the mac version! Surely everyone does not copy/paste their way around this issue....?
     
  13. lisanet

    lisanet Member

    Joined:
    Sep 15, 2008
    Messages:
    221
    Likes Received:
    0
    Trophy Points:
    16
    ... it does.

    sorry, but this has nothing to do with GIMP on Mac. The reason is that the default keyboard layout of X11 on Leopard doesn't use the ALT-key. So you either edit the ./Xmodmap file or use CTRL+X and CTRL+V

    .... it's about "cut" not "copy"

    -skl
     
  14. ouroboros

    ouroboros New Member

    Joined:
    Sep 5, 2009
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Okay thanks for this. So does this Xmodmap file mess any other apps or the OS up - or is it just for X11?
    :wilber:
     
  15. everazephyr

    everazephyr New Member

    Joined:
    Jun 11, 2014
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Hi,

    For me even the cut/copy and paste solution is no good. GIMP won't let me cut, copy, paste or clear selections. Nothing happens when I choose those options.

    I'm using OS 10.9.3 and GIMP 2.8.8.

    Any suggestions?
     
  16. everazephyr

    everazephyr New Member

    Joined:
    Jun 11, 2014
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    I ended up using a screen grabber to capture the different parts of the image and paste them back in as layers. Now I can (usually) cut and move selections. The bits that wouldn't move had originally been text but the text tool didn't select them anymore after I had merged down. I couldn't select them as text or as image. Screen grab was the workaround I found. I wonder what a better way would be.
     

Share This Page