hotkeys

Discussion in 'GIMP for Mac' started by jaap, Jul 4, 2011.

  1. jaap

    jaap New Member

    Joined:
    Jul 4, 2011
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    In Gimp I see letters underscored. I suppose these are hotkeys. But I cannot find how to activate these hotkeys on gimp for Mac.
    Is this possible, and How?

    regards Jaap
  2. Arzoroc

    Arzoroc Moderator Staff Member

    Joined:
    Oct 12, 2009
    Messages:
    2,201
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    Germany
    On Win/Linux I used ALT or CTRL + the key ... did you try the Mac versions of those keys?
  3. jaap

    jaap New Member

    Joined:
    Jul 4, 2011
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Thanks for help,

    Gimp is a bit confusing here.
    in 2.6 in prefs > hotkeys >screen all /most hotkeys are disabled.
    No way to enable the hotkeys here.
    this is confusing me.
    Solution: click on "disabled" and give the new hotkey in.

    A text below the screen does say this, but the "disabled" in a bit confusing.
  4. Arzoroc

    Arzoroc Moderator Staff Member

    Joined:
    Oct 12, 2009
    Messages:
    2,201
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    Germany
    Well, it's exactly that :p

    You click on the line (For example "Dialogs"), then you click on the "Disabled" and press your new hotkey(s) you want the command to have. Works fine for me :eek:
  5. UnconventionalT

    UnconventionalT New Member

    Joined:
    Jul 21, 2011
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    1
    I guess I'm just going to filter through the most recent posts and add some suggestions where I can.

    The first, and arguably the best fix, is to tell X11 (or XQuartz) to use the Apple command key as a replacement to the Alt or Crtl key. Here's a fantastic tutorial on how to do it: <a class="postlink" href="http://hints.macworld.com/article.php?story=20070206110939423" onclick="window.open(this.href);return false;">http://hints.macworld.com/article.php?s ... 6110939423</a>
    I've been using this method for a while now, and it works most of the time. Of course, it doesn't work when the Mac's default keyboard shortcuts conflict with Gimp's default keyboard shortcuts (as it does in the case of Command-H, which tells MacOSX to hide the windows, whereas in Gimp it supposedly anchors the current layer).

    Also, going back to what you were saying, it appears that X11 (and XQuartz) for Mac completely ignore the "Alt" key when using keyboard shortcuts. However, if you DO CLICK on a drop-down menu, you can still press the corresponding key on your keyboard to complete the shortcut.
  6. ~suv

    ~suv Member

    Joined:
    May 13, 2009
    Messages:
    49
    Likes Received:
    0
    Trophy Points:
    6
    SInce you have recommend to all users to install and use the latest Xquartz (instead of Apple's X11), I'm surprised you don't mention that more recent versions of Xquartz have a preference setting to make the 'alt/option' key work like the real 'Alt' key (instead of 'Mode_switch'). [1]

    The downside of this preference setting it that it changes both option/alt keys, and you loose the ability to use 'alt/opt' as compose key for diacritics and other special characters in text entries (there's an alternative way using xmodmap instead of the preferences GUI to modify only one of the two 'alt/option' keys, as described in the Inkscape FAQ »How to make the Alt key work»).

    [1] The problem with the alt/option key was originally reported in X11/Xquartz for games runing under Wine, but affects GIMP and Inkscape too:

Share This Page