1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Gimp can't directly open png, gif, bmp?

Discussion in 'GIMP for Windows' started by Shian, Jun 3, 2014.

  1. Shian

    Shian New Member

    Joined:
    Jun 3, 2014
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Hello, I am currently using gimp 2.8.1 on Windows 7 64-bit, and until recently I could open all images files just fine with gimp but now I have this problem:

    Right-clicking on an image no longer shows an "edit with gimp" option. Come to think of it I'm not sure if it was ever there in the first place. But anyway I found a guide and edited the registry so that all image files are edited by gimp. HOWEVER even if I right-click and select "edit" on any pngs, gifs or bmps, gimp opens but the image does not get imported into gimp (i.e. gimp opens as if I'd opened it from the executable). I can still load these file types with click and drag or the file->open option.

    Furthermore when I select open with->choose default program->C:\Program Files\GIMP 2\bin\gimp-2.8.exe, gimp doesn't show up in the program list, and clicking "ok" just opens the image in paint.

    What's even stranger is that the right click->edit with gimp option is available for ico and jpg files, and opening them that way works, however trying to open them in the same way as a png, gif, does causes the same problems and the image doesn't load in gimp.

    Reinstalling, restarting etc. doesn't work either. What should I do?
    Thanks in advance for any help.
     
  2. echo451

    echo451 New Member

    Joined:
    Jun 6, 2014
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Hi

    New to the boards here.

    It may be that the register edit string is incorrect.

    May I suggest you try a program called Default Program Editor. Google search should find it for you.

    I recently started using Gimp and wanted to be able to edit from the file explorer context menu.
    Rather then edit the registry directly this program takes care of the details. One of which is the program string to start an editor.
    It looks like part of the registry change is correct BUT the file name is not being passed to gimp.
    The program path should look like "C:\Program Files\GIMP 2\bin\gimp-2.8.exe" "%1" assuming that gimp is installed in the default location.

    It has a few other features that I find useful. You may have to change it for all the file types you want to edit using gimp. jpg, gif png etc.
    That may be a pain.

    Windows handles the open function well but not the edit.

    I hope this helps.
     
  3. Shian

    Shian New Member

    Joined:
    Jun 3, 2014
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Hi, after downloading the program you suggested and tweaking it a bit I managed to get the context menu to do exactly what I wanted. Even the open with->Gimp selection is fixed, even though I can't edit that specifically through the program. Weird right? But I'm not complaining as long as it works.

    Anyway thank you very much for the help!
     
  4. echo451

    echo451 New Member

    Joined:
    Jun 6, 2014
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Glad to help.

    New to gimp but old to windows. Always ready to help make life easier.

    Cheers
     

Share This Page