1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

GIMP 2.7.5 dependencies on Ubuntu 11.10 x64

Discussion in 'GIMP for Other' started by Bucic, Feb 10, 2012.

  1. Bucic

    Bucic Member

    Joined:
    Mar 14, 2010
    Messages:
    96
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Poland
    Recently I got updates to some gimp-related libraries through update manager. Unfortunately I allowed it to do a partial upgrade which involved removing my GIMP 2.7.4 installation. Now I see (in the SC) that 2.7.5 is available but I can't install it due to missing libraries / wrong versions. I have always used the matthaeus svn ppa.

    When I tried to install it through Software Center I got
    Code:
    The following packages have unmet dependencies:
    
    gimp: Depends: python-gtk2 (>= 2.8.0) but 2.24.0-2 is to be installed
          Depends: libc6 (>= 2.11) but 2.13-20ubuntu5 is to be installed
          Depends: libfontconfig1 (>= 2.8.0) but 2.8.0-3ubuntu2 is to be installed
          Depends: libgdk-pixbuf2.0-0 (>= 2.22.0) but 2.24.0-1ubuntu1 is to be installed
          Depends: libglib2.0-0 (>= 2.31.2) but 2.30.0-0ubuntu4 is to be installed
          Depends: libgs9 (>= 8.61.dfsg.1) but 9.04~dfsg-0ubuntu11.5 is to be installed
          Depends: libgtk2.0-0 (>= 2.24.0) but 2.24.6-0ubuntu5 is to be installed
          Depends: libgudev-1.0-0 (>= 147) but 1:173-0ubuntu4.1 is to be installed
          Depends: libjpeg62 (>= 6b1) but 6b1-1ubuntu2 is to be installed
          Depends: librsvg2-2 (>= 2.14.4) but 2.34.1-2 is to be installed
          Depends: zlib1g (>= 1:1.1.4) but 1:1.2.3.4.dfsg-3ubuntu3 is to be installed
    I used the 'dep' command and got
    Code:
    ~$ sudo apt-get build-dep gimp
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    The following NEW packages will be installed:
      gawk krb5-multidev libaa1-dev libart-2.0-dev libasound2-dev libbabl-0.0-0-dev
      libcups2-dev libcupsimage2-dev libcurl4-openssl-dev libffi-dev libgegl-0.0-dev
      libgs-dev libgssrpc4 libgtk-3-dev libhal-dev libidn11-dev libijs-dev libjasper-dev
      libjbig2dec0-dev libjpeg62-dev libkadm5clnt-mit8 libkadm5srv-mit8 libkdb5-5
      libkrb5-dev liblcms1-dev libldap2-dev libmng-dev libncurses5-dev libpaper-dev
      libpoppler-dev libpoppler-glib-dev librsvg2-dev libsigsegv2 libslang2-dev libssl-dev
      libtiff4-dev libtiffxx0c2 libtinfo-dev libwmf-dev libxmu-dev libxmu-headers libxpm-dev
      libxt-dev libzip-dev libzip1 patchutils python-dev python-gobject-2-dev
      python-gobject-dev python-gtk2-dev python-rsvg python2.7-dev xvfb
    0 upgraded, 53 newly installed, 0 to remove and 0 not upgraded.
    Need to get 24,6 MB of archives.
    After this operation, 99,7 MB of additional disk space will be used.
    Do you want to continue [Y/n]? 
    Y
    Code:
    ~$ sudo apt-get install gimp
    
    .
    .
    .
    The following packages have unmet dependencies:
     gimp : Depends: libglib2.0-0 (>= 2.31.2) but 2.30.0-0ubuntu4 is to be installed
    E: Unable to correct problems, you have held broken packages.
    
    So it looks like I had narrowed it down to one missing library. How can I resolve this? I need GIMP for my work!

    EDIT:
    The script <a class="postlink" href="http://www.zanshine.com/blog/stephane-richard/software/2011-10-05/cutting-edge-gimp-in-latest-ubuntu/" onclick="window.open(this.href);return false;">http://www.zanshine.com/blog/stephane-r ... st-ubuntu/</a> also reported the same problem with libglib2.0-0 (>= 2.31.2)

    EDIT:
    I tried installing the package from <a class="postlink" href="http://packages.debian.org/sid/libglib2.0-0" onclick="window.open(this.href);return false;">http://packages.debian.org/sid/libglib2.0-0</a> but I got
    Code:
    ~/Downloads$ sudo dpkg -i libglib2.0-0_2.30.2-6_amd64.deb
    [sudo] password for hg1: 
    (Reading database ... 342598 files and directories currently installed.)
    Preparing to replace libglib2.0-0 2.30.0-0ubuntu4 (using libglib2.0-0_2.30.2-6_amd64.deb) ...
    De-configuring libglib2.0-0:i386 ...
    Unpacking replacement libglib2.0-0 ...
    dpkg: error processing libglib2.0-0 (--install):
     libglib2.0-0:amd64 2.30.2-6 cannot be configured because libglib2.0-0:i386 is in a different version (2.30.0-0ubuntu4)
    dpkg: error processing libglib2.0-0:i386 (--install):
     libglib2.0-0:i386 2.30.0-0ubuntu4 cannot be configured because libglib2.0-0:amd64 is in a different version (2.30.2-6)
    Errors were encountered while processing:
     libglib2.0-0
     libglib2.0-0:i386
    
     
  2. gimpeRaven

    gimpeRaven Member

    Joined:
    May 28, 2010
    Messages:
    455
    Likes Received:
    1
    Trophy Points:
    18
    Occupation:
    a college student, a Gimper and a gamer
    Home Page:
    Does the old Gimp version of 2.7 still works? It's weird if you updated the libraries and the new one don't work.. :wilber:
    I am only guessing: How about re updating the updates? Sorry, I am just starting using Linux Mint so I don't know much. ;D
     
  3. Bucic

    Bucic Member

    Joined:
    Mar 14, 2010
    Messages:
    96
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Poland
    The 2.7.4 has been removed. Updating won't bring it back, nor it won't bring back the previous versions of libraries.

    Any 2.7.x will be fine. If anyone knows a method to make any 2.7.x work, please speak up.
     
  4. Bucic

    Bucic Member

    Joined:
    Mar 14, 2010
    Messages:
    96
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Poland
    <a class="postlink" href="http://ubuntuforums.org/showthread.php?t=1923311&page=2" onclick="window.open(this.href);return false;">http://ubuntuforums.org/showthread.php?t=1923311&page=2</a>
     
  5. Bucic

    Bucic Member

    Joined:
    Mar 14, 2010
    Messages:
    96
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Poland
    Solved.
    <a class="postlink" href="http://ubuntuforums.org/showthread.php?p=11683286#post11683286" onclick="window.open(this.href);return false;">http://ubuntuforums.org/showthread.php? ... st11683286</a>
     

Share This Page