Color change in the GIMP window

Discussion in 'General GIMP help' started by nec00005, Apr 10, 2012.

  1. nec00005

    nec00005 New Member

    Joined:
    Apr 10, 2012
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    I have been having problems with images that I save appearing to be more saturated and have more contrast than the edit looks in the GIMP window. I tried playing around to figure out what it might be and found that when I open an image in GIMP, the image displayed in the program is less saturated and less contrasty than the original image without any changes made. When I save the unedited image, the new image looks like the old image, both more saturated and contrasty than the image displayed in the GIMP window. Because of the color change in the GIMP window, all of my edits are pointless because it is not showing me the correct outcome. My images are originally JPG format and I save/export in JPG format. Any idea of how to fix this? Attached is a screencap. The original image/what the unedited saved image looks like is in the preview window on the right. The image on the left is the unedited image opened in the GIMP window.
     
  2. Arzoroc

    Arzoroc Moderator Staff Member

    Joined:
    Oct 12, 2009
    Messages:
    2,201
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    Germany
    There is no screencap attached to your post, so you probably made a mistake there ;)

    Back to your problem. I never heard of this before. Are you working on a clean and fresh install of Gimp? If you don't, try the usual advice we give here:
    Tell us if there's any difference. If there isn't, maybe Rod can help you with some tech-y stuff.

    Good luck
     
  3. nec00005

    nec00005 New Member

    Joined:
    Apr 10, 2012
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Ok I cannot figure out how to upload the screencap file. Maybe it's just in the wrong format. Anyways, thanks for your suggestions. I will try your suggestions. I should mention I am using OS X.
     
  4. nec00005

    nec00005 New Member

    Joined:
    Apr 10, 2012
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Here is a link to a post in another forum with an example of what I am talking about: <a class="postlink" href="http://gimpforums.com/thread-color-change-in-the-gimp-window" onclick="window.open(this.href);return false;">http://gimpforums.com/thread-color-chan ... imp-window</a>
     
  5. Maffe811

    Maffe811 The forum pet Staff Member

    Joined:
    Jul 2, 2009
    Messages:
    6,811
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    Norway/Norge/Norwegen
    Yep, that helps.

    If the problem happens when you save, check your save settings.
    It should be mentioned that only a few of us use a Mac.

    Is this problem recently happening or has it been this way all along.

    Also, just try to google arround while you wait for an answear.
     
  6. David Wood

    David Wood Active Member

    Joined:
    Jul 22, 2009
    Messages:
    5,476
    Likes Received:
    0
    Trophy Points:
    36
    Occupation:
    Freelance graphic designer and visual effects arti
    Location:
    Western New York
    Home Page:
    As Ofnuts said on gimpforums, it's probably a color profile issue. Check under the preference menu's color management tab.
     
  7. nec00005

    nec00005 New Member

    Joined:
    Apr 10, 2012
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    I have tried changing the color profiles with no luck. I have tried changing the saving settings with no luck. And I have tried changing my computer display settings with no luck. I have tried googling with no luck! Lol I do not know when the problem started. I want to say when I updated versions a few months ago but i've only really noticed it now because I have been too busy to edit things. Anyone know of where to get an older version of GIMP so I can try this theory out? I have tried viewing the image on my iPhone and my PC (not in GIMP) and it looks like my computer's preview/opened. I opened the picture in GIMP on my PC and the colors match the preview/opened image. The only thing displaying the wrong colors is when the image is opened in GIMP on my Mac. I changed every setting on my Mac GIMP to match the settings on my PC GIMP and it still did not fix the problem. Any ideas?
     
  8. Maffe811

    Maffe811 The forum pet Staff Member

    Joined:
    Jul 2, 2009
    Messages:
    6,811
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    Norway/Norge/Norwegen
    So it comes when you open the image too ?

    Yes, i got one, is it multiple file types or only one?
    Im thinking some corrupt file.
     
  9. nec00005

    nec00005 New Member

    Joined:
    Apr 10, 2012
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    The file type is JPG and it happens with every image, including images taken with different cameras.
     
  10. David Wood

    David Wood Active Member

    Joined:
    Jul 22, 2009
    Messages:
    5,476
    Likes Received:
    0
    Trophy Points:
    36
    Occupation:
    Freelance graphic designer and visual effects arti
    Location:
    Western New York
    Home Page:
    You could try desaturating the image by 20 or 30 percent and then saving, it's a workaround but should do the trick.
     
  11. nec00005

    nec00005 New Member

    Joined:
    Apr 10, 2012
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Yeah I have been doing that and adjusting to make it more blue/green/cyan and it's working but it's a hassle to get it the right color. Thanks.
     
  12. Maffe811

    Maffe811 The forum pet Staff Member

    Joined:
    Jul 2, 2009
    Messages:
    6,811
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    Norway/Norge/Norwegen
    I would suggest reinstalling the jpg plugin thing if its only jpg
     
  13. Rod

    Rod Moderator Staff Member

    Joined:
    Apr 19, 2010
    Messages:
    1,740
    Likes Received:
    0
    Trophy Points:
    36
    Recalibrate your monitor to correct colors.If you have been mucking with it.
    Start Gimp.Gimp should have your colors set MANUALLY to 72-98 dpi.
    Edit>Pref>Display - make sure auto is checked.Restart Gimp and see if that helps.
    Anything you see off of Gimps display like say in your image viewer, should be the same dpi as in Gimps display window.
     
  14. nec00005

    nec00005 New Member

    Joined:
    Apr 10, 2012
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    I deleted GIMP and the entire Application Support>Gimp folder and reinstalled it all. It's still doing the same thing. If I remember correctly, it also happened with the .xcf files but my camera's default setting is jpg so I don't know if that might have something to do with it. Thank you everyone for trying to help.
     
  15. Maffe811

    Maffe811 The forum pet Staff Member

    Joined:
    Jul 2, 2009
    Messages:
    6,811
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    Norway/Norge/Norwegen
    Make sure you did delete ALL gimp files, everything, even the hidden ones! :p
     
  16. Rod

    Rod Moderator Staff Member

    Joined:
    Apr 19, 2010
    Messages:
    1,740
    Likes Received:
    0
    Trophy Points:
    36
    Did you go to Edit>Pref>Display then check Detect automatically?
     

Share This Page